W0007967 - Workhorse W-series Wiper Control Module

W0007967 - Workhorse W-series Wiper Control Module

PLEASE READ!!!

Order Shipment Notice: 

Most orders are shipped within 24 hours from the order date. Orders placed on the weekend or after cutoff on Friday, and orders placed on select holidays are processed on the next business day. Please see our shipping terms for more information.

Part# W0007967 - Workhorse W-series Wiper Control Module


We recommend adding the 15 amp Mini Auto Reset Circuit Breaker to go in place of the 25 amp fuse in position # 22 on your interior fuse panel. This way a amperage spike will trip the breaker instead of ruining the module.


 Description:

  • Workhorse W-Series Wiper Control Module

Applications:

  • All Workhorse W-Series

Replaces:

  • W0000334
  • W0002648

Click Here for Diagnostic Information


the other day the cab of my rv filled with smoke and after the smoke cleared the wipers didn't work... I discovered the wiper control module had caught fire. I can't tell what the P/N is, it appears to be W0000334/ AC 2003 and model 1311. Will this part work? it looks very similar 2002 Fleetwood Pace arrow Workhorse chassis. Also, where can I get the plug that would insert into the module? Thank you for your help ( Bradley, 10/17/2021 )
Hi Bradley , can you email us your chassis VIN and we can verify part # and determine the correct plug also , help@workhorseparts.com    ( Support )
Hello i bought as new wiper control modual from you P/N: W0007967 DC 1 181 MODEL1312 I received the module and installed it as my other issue was with old module only work on high.
This solved the problem except home, were the wipers park is when they are extended far apart. How do get it to have them together in the center of windshield as intended. The only difference in the numbers from my old module MODEL 1311 and is DC 4 288.
( Tim Waldron, 09/12/2021 )

Hi TIm,

    Usually when there is an issue with the park position it is the motor. Which would make sense that the wiper control failed, because it is probably drawing too many amps through the controller. Make sure to replace the fuse for the wipers with a breaker as stated on the product page for that part on our website. 

We recommend adding the 15 amp Mini Auto Reset Circuit Breaker to go in place of the 25 amp fuse in position # 22 on your interior fuse panel. This way a amperage spike will trip the breaker instead of ruining the module.
( Support )
I INSTALLED A NEW WIPER MODULE AND ANEW WIPER MOTOR .I ALSO INSTALLED A I5 AMP BREAKER AS IT WAS SENT WITH THE NEW MODULE. ON A DRY WINDSHIELD IT STOPS WORKING AFTER ONE PASS OF THE WIPER BLADES.THE BREAKER TRIPS , TO RESET THE BREAKER I HAVE TO TURN OFF THE IGN.WHEN I TURN THE IGN BACK ON IT HAPPENS AGAIN.DOE'S RUNNING THE WIPER ON A DRY WINDSHIELD DRAW TO MANY AMPS. ( stan kobrin , 04/15/2021 )
Sounds like you have a bad wiper motor. Yes, using the wipers on a dry windshield will draw more amps, however it should not draw enough to trip that breaker after one pass. Replace the wiper motor and you should be all set. When you have the wiper motor removed make sure your linkage all moves freely as well. Wiper motors were supplied by the body builder, but most of the time you can just to an internet search of the numbers you find on the one you have and find one fairly easily. ( Support )
I got the new module and installed it, works fine now but I question replacing a 25 amp fuse for a 15 amp breaker ( Gary L Potts, 10/27/2020 )

Gary,

    The reason Workhorse recommends replacing that fuse with that breaker is due to drawing more than 15 amps through the wiper module destroys them. The 15 amp breaker will open momentarily if the amp draw exceeds the 15 amps of current, which saves the wiper modules. You certainly do not have to use the breaker, but you may be replacing the wiper module again in the near future without it.

( Support )
I changed my wiper motor after it broke down on the road at a RV repair shop. Worked fine for 3 weeks , Now as I turn on the engine the wipers go on without stopping even when the control switch at off. Returned to RV store got it replaced, worked fine for about 3 months , now doing the same thing, doesn`t stop, no intermitted only runs on low or high.. Could this be a module problem? ( Pierre D'Avignon, 07/08/2020 )
Not answered yet.
have a 2005 Simba Safari motorhome on a workhorse chassis. the wipers only work on the high setting, no other function works. would this most likely be the control module or the selector on the steering post ? it only has 7000 miles on it. ( Bill Ferguson, 07/07/2020 )
Your issue sounds more likely to be the wiper control module. ( Support )
My 2007 trek wipers run with just the ignition on. Can change the speed but cannot turn of with wiper switch. ( Bill, 05/21/2020 )
With what you are describing, I would agree that the wiper control module is the issue. However I would encourage you to look through the diagnostics that are available on the product page at the bottom of the description area. ( Support )
I'm looking for a windshield wiper control assembly for my Workhorse, 2002 P35 Chasis. (Itasca RV) ( murray mcleod, 06/09/2018 )
The wiper control pulse module for the P32 is part # 15598496. ( Support )
I have a 2007 workhorse Motorhome w24 . The wipers turn on fine . I have all speeds but sometimes they won't shut off at the wiper switch . Or driving down the road the wipers will come on by there self in the off position . Help ??? ( Delbert Todd , 04/06/2018 )
Not answered yet.
1. I have W007967 model 1312 but has a DC 0 085 on it same part #
2.if this a wiper module why does it have brake shift to park on it?
After these are answered I will order one
( Robert Almgreen, 08/22/2017 )
Yes this is the same part. The reason it has the transmission indicator on it is for when the chassis was moved around the lot before the body was put on it. It has no effect on transmission operation. ( Support )
2002 Fleetwood Storm 30H - Chevy Workhorse 8.1 V8 MFI P32 I am experiencing an issue with my wipers going on without being activated. When they do this they go on for one complete cycle. It does this when I turn the key to the "on" position and when I use either turn indicator. Once in a while they will go on with no discernible prompt whatsoever (perhaps due to accelerating or gears shifting?). I have checked both plugs for corrosion. I pulled the motor and cleaned the contacts on the housing. I have visually inspected as many ground points as I could find. This is a well-maintained vehicle (not rusted or corroded). There are no other apparent electrical issues. Any ideas? ( Chris, 06/20/2017 )
Not answered yet.
Hello,

My wipers only work on high speed. Turn signal, cruise control works. When i disconnect the module the turn signal works and the wipers work on high speed. Is this the module to replace or is it somethingelse?

Thanks,
D
( D, 06/07/2017 )

D,

The Symptoms you describe definitely sound like a failed wiper module.

( Support )
This is a P12 chassis with a logic module (sure power industries inc) P/N 15740681 Model: 1306GM.
I'm having trouble finding this particular part, the workhorse came in production a year or two later, I see you have for them a close logic module P/N W0007967, this is the closet I've come to finding one (not to many Sure Power out there)
Is there any suggestions you might be able to help me with this problem I'm having ?
is there anyway I can cross one with another ?
A 1998 Winnebago Vector 37B
Thanks for your time.
Jeff
( Jeff Lutz , 08/29/2016 )

Hi Jeff,

Unfortunately this part has been discontinued and I do not have a cross into a Workhorse part #. I did do some searching online and found a few places that still have that part in stock. Here is a link to one of those places: http://bullseyeindustrialsales.com/sure-power-1306gm-15740681-electric-module-77951

( Support )
I ordered the W0007967 from you and it is on its way to me. I understand that the module it on top of the steering column support. Can you offer any suggestions as to the easiest way to replace the module. I was thinking that I could remove the plastic cover on the steering assembly and possibility reach it through the opening. I am a little less flexible than I was in the past.

Thanks
Dennis
( Dennis Walczak, 07/14/2016 )

Dennis,

Unfortunately there usually is no "easy" way to replace this module. The only exception are the Winnebago and Itasca's with the flip up dash. If you can remove your instrument panel that may give you enough room to reach in and get it.

( Support )
Windshield wipers consistently turn on with the ignition ONLY following a rain storm until the weather dries out, even when the vehicle is parked. Can only stop by removing the fuse. On a 2009 Winnebago Adventurer 32H and is reported online as a common issue with Workhorse chassis.

I have waterproofed the connector to the motor with dielectric grease and a electrical tape with no luck. I find that the "park" wire going to the motor is ultra sensitive to any leakage path to ground (such as a 12V test light) which reproduces this problem. Winnebago tech support suggested contacting Workhorse for help. I don't want to buy a new motor or control module if the problem is elsewhere. It must be on the outside of the coach because there is no exposure to moisture from rain inside. Please describe location of wiper control module in my RV. Thanks for your help. This is a very frustrating problem.
( Leo Lewis, 05/20/2016 )

Leo,

The wiper control module is located on top of the steering column support behind the dash. If you were to get on your back and look up under the dash it's going to be bolted to the flat top piece of that support. If you need further diagnostic help with this issue we can send some diagnostic aids.

( Support )
The wipers on my motorhome work on high only no low speed or intermittent and no park. I have replaced the control switch and the wiper motor with nno luck now think it may be the moduel w0007967 is there any way to check any help greatly appreciated.need to fix asap leaving on 5/13 for beach ( monroe hall, 05/06/2016 )

Monroe,

      Do you have the last 8 digits of your VIN so that I can try to help out with the issue?

( Support )

Ask a question

Note: HTML is not translated!

Write a review

Please login or register to review

 The state of California requires that this warning be posted for people purchasing products that reside in California.

WARNING: Products may contain one or more chemicals known in the State of California to cause cancer and/or birth defects or other reproductive harm. For more information, visit www.P65Warnings.ca.gov

Shipping Insurance Notice

NOTICE: For orders outside of United States

If you are placing an order to ship outside the United States, Shipping Insurance will be required and added automatically at checkout.

      

  • Views: 55286
  • Brand: Workhorse
  • Product Code: W0007967
  • Availability: 73
  • $182.44
  • $135.14

Available Options